Unable to disable UM Mailbox on after upgrading to MS Exchange 2010

>> Friday, 8 June 2012

Unable to disable UM Mailbox on after upgrading to MS Exchange 2010
as the title of this particular thread is saying I am not able to disable UM Mailbox. Recently I have upgraded Exchange 2010 from Exchange 2007. In Exchange 2007 I was using UM as well. there are six users who are looking to upgrade with new server and wanted to enable UM on Exchange 2010. One of use switched UM Mailbox policy to Exchange 2007. User is not able to get receive voicemails after reporting an issue.
so I told that user to disable UM and after sometime enable it. but that user was not able to enable UM at all. when I have look on powershell commands it got that it was already enabled. I got couple of results while using two different command. I am using powershell on Exchange 2007. I tried everything to make the thing working but I was not able to fix it. when I am clicking on Reset Unified Messaging PIN in 2010 EMC I am getting below mentioned error message.
‘The user 'username' isn't UM-enabled or is UM-enabled and has a mailbox whose version isn't supported by this Unified Messaging server. It was running the command 'Get-UMMailboxPIN - identity 'user'.’

This particular user is on 2010 mailbox server and everything is working without having any major issue until and unless someone is changing UM mailbox policy to older policy.
Let me know if you are having useful information to resolve my issue.
Reply With Quote
#2
Old 27-04-2012
Badrinath Badrinath is offline
Member

Join Date: Jun 2008
Posts: 207
Re: Unable to disable UM Mailbox on after upgrading to MS Exchange 2010
I am suspecting that you are not able to update the dial plan for that user on powershell of Exchange 2010 dial plan. Do you using adsi or attribute editor which will help you to modify msExchUMRecipientDialPlanLink attribute on your user account? So answer above mentioned question so that I can figure out the root cause of problem.
Reply With Quote
#3
Old 27-04-2012
Aaryan2011 Aaryan2011 is offline
Member

Join Date: Aug 2011
Posts: 332
Re: Unable to disable UM Mailbox on after upgrading to MS Exchange 2010
Well I was also suffering from the same problem which you have mentioned over here. I have gone through ADSI and figured out that one of the field was broken and it was not working at all. mxExchUMRecipientDialPlanLink was removed as admin changed dial plan for old 2007. I simply copy and pasted this particular information from the profile of working UM user and completed replication. After doing that everything started to work again.

0 comments:

Post a Comment

Read - Share - Comment

About This Blog

Share and Save

About Author